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SYSTEM OVERVIEW 
 
The Drive By Download ™ (DBD 3) PC utility manages the wireless communication with truck mounted data storage 

devices.  The data retrieved from trucks is used to monitor truck events and optimize fleet performance.  Some of the data 

that can be collected includes: 

  

 Truck Location (GPS), Speed, etc. 

 Road/Air Temperature 

 Materials Dispensed 

 Digital/Analog Inputs 

 

DBD 3 is compatible with the SpreadSmart
 

Rx ™ and DataShark™ systems.  Wireless communication is achieved 

through an access point which is connected to the computer.   The access point is mounted at a location trucks will visit 

during normal operations (fuel, sand/salt, deicing chemical storage sites).  When trucks arrive within 250 feet of the 

access point, the PC initiates a download of the data stored in the truck.  DBD 3 collects and stores the data in log files 

which can be accessed and analyzed at any time. 
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INSTALLATION 

Requirements 
Windows XP or Windows 7 operating system 

 

Installing the Software 
Step 1: Place the CD into your CD Drive and the program will start to install automatically. If the installation does not 

start automatically follow these steps: 

a. Open the My Computer icon on your desktop. 

b. Right click on the CD drive the DBD 3 program is in. 

c. Left click Explore. 

d. Double left click on the setup.exe file on the CD. 

 

Configuration 
DBD 3 is now installed and needs to associate an IP Address and Vehicle ID to each truck in your fleet so the computer 

can communicate with them.  The configuration file (DriveByDownloadConfigurationFile.cfg) provides a user friendly 

way to add trucks to your fleet.  DBD 3 comes with a configuration file on the installation CD which is prepared at the 

factory to reflect your custom program settings, as well as truck information.  To install the configuration file in DBD 3 

go to File->Import Configuration File.  Select the file DriveByDownloadConfigurationFile.cfg from the CD.  After 

importing the configuration file the Full Vehicle List is populated with the trucks in your fleet.   

 

Trucks can also be added to the fleet one at a time using Full Vehicle List->Add Vehicle menu item. 

 

Choose Log File Location 
Choose a folder to store the log files where all of the downloaded data is stored.  DBD 3 will create subfolders which sort 

downloads by truck type and IP Address.  To change the location of the log files select File->DBD 3 Log File Location. 

 

Change/Update the Sleep Mode of the Computer 
Your computer must be on at all times so that DBD 3 can collect data from arriving trucks.  To keep your computer on all 

of the time you must turn off the sleep mode. 

 

Windows 7 
Start->Control Panel->Power Options 

Click on „Choose when to turn off display‟ 

Make sure Turn off the display and Put the Computer to Sleep are set to Never. 

 

Windows XP 
Start->Control Panel->Power Options 

Click on the Power Schemes tab. 

Make sure Turn off monitor, turn off hard disks, system standby, and system hibernates are set to Never. 

 
To verify that trucks are downloading, click on a vehicle in the Full Vehicle List that is believed to have downloaded data.  

All of the settings for the selected truck should be visible in the Vehicle Settings.  The time/date of the Last Download 

will display the last time the truck downloaded data.   
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System Details 
 
DBD 3 is a utility designed to store the data from SpreadSmart™ and DataShark™ in the form of Log Files. 

 

The program runs in the background on a PC with no user interaction required.  Once a fleet of trucks has been 

configured, DBD 3 searches for trucks in range of the Access Point and collects their data.  The DBD 3 program must 

remain open in order to collect data, but it does not need to be monitored.  Successfully downloaded data is verified 

accurate.  The user interface assists in fleet configuration and is useful for troubleshooting any trucks that may be having 

difficulty downloading.  The Download Faults List updates, in real time, any trucks that have problems downloading.  An 

alternative way to monitor the download status of trucks is to configure the Fleet Overview emails which can be delivered 

every 1 to 28 days.  The Fleet Overview report allows supervisors to confirm the data is being collected in a timely 

manner.     

Fleet Configuration 

DBD 3 needs to know which IP Address each truck in the fleet has to establish communication.  The fleet can be setup 

manually or automatically using a configuration file.  A configuration file can be obtained from Cirus Controls if you 

know the IP Addresses of the trucks.  Manual entry requires the user to go to Full Vehicle List->Create New Vehicle and 

enter the data in the Vehicle Settings section of DBD 3.  Each truck must have a unique IP Address and Vehicle ID.  The 

one exception to the unique Vehicle ID rule is the name „Cirus‟.  If the Vehicle ID is „Cirus‟, a warning message will 

appear whenever DBD 3 is opened.  The warning advises the user that unique Vehicle ID‟s help distinguish between 

trucks. 

Downloading 

All of the „Active‟ trucks in the fleet are continuously scanned to trigger a download.  Trucks set to „Active‟ will 

download their data to Log Files when they come into range of the access point.  When a truck is set to „Inactive‟, it will 

not download even if the truck comes into range of the Access Point.  Successful downloads will not be noted anywhere 

on the user interface, and the data will be stored in Log files kept in the DBD 3 Log File Location.  The last time a truck 

has downloaded can be found by clicking on a vehicle in the Full Vehicle Listing and viewing the Last Download time in 

the Vehicle Settings.  Unsuccessful downloads will be listed in the Download Faults List.  If a problem occurs during 

download, the download is stopped and DBD 3 will attempt another download after three minutes.  

 

Analyzing the Data 

Drive by Download™ includes software called Data Analysis Tool which converts the Log Files into reports containing 

graphs and tables providing easy analysis of the collected data.  The Data Analysis Tool also has the ability to create 

Shape files for ArcView and other GIS systems. 
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USER INTERFACE 
 
The user interface is divided up into three sections: 

 Full Vehicle List 

 Vehicle Settings 

 Download Faults List 

 

 

Full Vehicle List 
The Full Vehicle List contains all of the trucks configured in to the system.  Trucks listed in white text are active and will download 

when the truck is in the range of the Access Point.  Trucks listed in teal text are inactive and will not download when a truck is in 

range.  Trucks with a green background color are in range of the access point.  Trucks that have an orange background color are not in 

range of the access point. 

Vehicle Settings Panel 

The Vehicle Settings panel provides an area where a truck‟s settings can be edited and its communication examined.  The 

truck loaded into the Vehicle Settings has the vehicle ID with the first two characters of the Vehicle Type located below 

the Vehicle Settings title.  A new vehicle can be chosen by clicking any vehicle ID in the Full Vehicle List or the 

Download Faults List.  The „Download Vehicle Data‟ button allows the user to download a truck if it is in range.  The red 

„Truck Out Of Range‟ text will appear when a truck is not close enough to the Access Point to download.  Green „Truck 

In Range‟ text will appear when a truck is close enough to the Access Point to download.  The Truck Communication Test 

button will test communications with the truck without doing a data download.  The Vehicle Settings provide the ability to 

edit the Vehicle ID, IP Address, Subnet, Vehicle Type, and Vehicle State.  The Vehicle Settings panel displays the Last 

Download time/date and the Download Fault if there was a problem with the last download.  Editing is done by clicking 

the „Edit Vehicle Settings‟ button and the „Save‟ button when the changes have been made.  The IP Address of every 

truck must be unique, so DBD 3 will not allow a truck to be saved if it is a duplicate IP Address.  The truck ID must be 5 

or less characters long and must also be unique unless it is named „Cirus‟.   

Download Faults List 

The Download Faults List contains all of the trucks with a download error.  That error is displayed in a tooltip when the 

user places the computer mouse over the truck listed in the Download Fault List.  Individual Download Faults are also 

visible in the Vehicle Settings. 
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File Menu 

 

Import Configuration File 

Imports a configuration file (.cfg) which supplies all of the fleet data necessary for downloading. 

Export Configuration File 

Exports a configuration file (.cfg) which contains all of the fleet data necessary for downloading. 

DBD 3 Log File Location 

Allows the user to change the location of the log files which contain the data downloaded by the trucks.   

The current location of the DBD 3 log files is displayed on the bottom left corner of the DBD 3 program. 

DBD 2 Functions 

Update DBD 2.2 Log Files to DBD 3 
A utility used to convert the log files created from DBD 2.2 into a form that is usable in DBD 3.  Before converting files it 

is recommended that you set all of the vehicles in the Full Vehicle List that you are updating to the INACTIVE state so 

they will not download data while the conversion is occurring.  

 

Upload DBD 2 Vehicles Into DBD 3 

This utility is used when upgrading from DBD 2 to DBD 3.  It will upload the truck ID and IP address of each 

truck in DBD 2 and place them into DBD 3.  Using this utility eliminates the need to manually enter the vehicle 

ID and IP Address of each vehicle you wish to use in DBD 3 that was present in DBD 2.  Note that the 

maximum length of the vehicle ID in DBD 3 is five characters.  If there are vehicles in DBD 2 with truck ID‟s 

that are longer than 5 characters, you will be asked to shorten them before they can be used in DBD 3.   
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View Menu 

 

Full Screen View 

Displays the Full Vehicle List, Vehicle Settings, and Download Faults List at its maximum size. 

Download Fault View 

Displays only the Download Faults List. 

Normal View      

Returns DBD 3 to its original size when Full Screen View or Download Fault View have been selected. 

Full Vehicle List Menu 
 

 
 

Create New Vehicle 

Provides a way for the user to add a truck to the fleet.  The vehicle data is edited in the Vehicle Settings section and a new 

vehicle is created when the „Save‟ button is clicked. 

Sort List By 

Sorts the Full Vehicle List in the chosen manner: 

 By Vehicle ID 

 By IP Address 

 By Last Download 

 By Vehicle Type 

 By Vehicle State 
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Delete Vehicle From System 

Provides a way for the user to delete a truck from the fleet. 

Delete All 

Deletes all of the trucks in the Full Vehicle List, which removes all of the trucks available to download data. 

Download Faults List Menu 

 

Remove Vehicle 

Removes the vehicle selected from the Download Faults List. 

Remove All 

Removes all of the vehicles from the Download Faults List 

Preferences Menu 
 

 

Ping Timeout 

This is the amount of time DBD 3 will attempt to ping a truck.  Pings are used to determine whether a truck is in range of 

the wireless base station (Access Point).  The minimum time allowed is 200 milliseconds and the maximum time allowed 

is 2 seconds.  When this value is set to 2 seconds, it will become easier for trucks to be considered in range, but takes 

longer to check if a truck is in range.  When set to 200 milliseconds, it will become harder for each truck to be considered 

in range, but will determine if each truck is in range quickly. 

 

The ping timeout value determines the time it takes DBD 3 to scan an entire fleet of trucks to verify if they are in range or 

not.  The maximum amount of time to scan a fleet of trucks can be calculated the following way: 

 

Time to Scan Fleet = (ping timeout)  x (number of Active trucks in the fleet)  
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Download Interval 
The download interval is the minimum amount of time required to elapse before another download can be attempted.  The 

minimum amount of time is 5 minutes, and the maximum time is 2 hours.  The download interval eliminates the 

possibility of a truck being parked at the base station (access point) and continuously downloading, tying up the 

computer‟s resources. 

 

Email Options 
There are two email features in DBD 3: 

Email Fleet Overview 

 Email Configuration file 

Email Fleet Overview allows a user to receive emails at predefined intervals (set by Preferences->Email Options->Fleet 

Overview Message->Message Frequency) that contain the Fleet Overview Report. This report is only emailed when 

selected and when there is a truck which falls into any of the categories listed in the report 

.   

Email Configuration File allows the user to email a copy of the configuration file.  The user can enter a list of addresses to 

send the information to, and email the file.  This function allows Cirus Controls to have easy access to the configuration 

file when new equipment is installed, a new configuration file can easily be updated. 

 

Company Name 
Provides a name which is used in all of the reports provided by DBD3. 

Reports Menus 
 

 
 

Full Vehicle List - Short Version 

Creates a text file which contains all of the trucks in the fleet and details their vehicle ID, IP Address, and Subnet Address. 
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Long Version 
Creates a text file which contains all of the trucks in the fleet and details their Spreader Type, IP Address, Subnet, Vehicle 

Type, Vehicle State, Last Download Time, Download Error. 

 

 
 

 

Fleet Overview 
Creates a text file which lists all of the trucks that have not downloaded in the previous 1, 7, and 28 days.  It also details 

which trucks have never downloaded, which trucks are displayed in the Download Faults List, and lists the trucks which 

are inactive. 
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Help Menus 

 

Drive By Download ™ 

Help menus for DBD 3. 

Cirus Test 

Used for advanced testing and troubleshooting in the presence of a Cirus Controls employee. 

About 

DBD 3 version number. 
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COMMON FUNCTIONS 

Adding Vehicles to the Fleet 

Vehicles can be added to the fleet by clicking on Full Vehicle List->Create New Vehicle.  The vehicle is edited using the 

Vehicle Settings panel. 

Removing Vehicles from the Fleet 

To delete a vehicle from the fleet, click on Full Vehicle List->Delete Vehicle From System and select the truck. 

Removing Vehicles From the Download Faults List 

There are two ways to delete a vehicle from the Download Faults List. 

1. Click on the vehicle in the Download Faults List that you want to delete.  Then click on the button at the bottom 

of the Download Faults List. 

2. Go to Download Faults->Remove Vehicle to remove only one vehicle or Download Faults->Remove All to clear 

the entire Download Faults List. 

Locating DBD 3 Log Files 

The user interface shows the folder being used to store Log files in the bottom left corner of the screen.  The location can 

be changed by going to File->DBD 3Log File Location.   

DBD 3 Log File Location Folder 

 

The following tree shows the hierarchy and an example of the naming conventions. 

 

 

DBD 3 Log File Location Folder 

 

 

Truck Type Folder 

 

 

Individual truck Folder 

 

 

Log Files 

 

 

 

DBD 3 Log File Location Folder – the folder selected by the user using  

        File->DBD 3Log File Location. 

 

Truck Type Folder – A folder is created for each type of truck being used. 

 

Individual Truck Folder – A separate folder is created for each truck using the naming convention  

 

AABBBBBCCCCCCCCCCCC where: 

AA = first two characters of the truck type 

 BBBBB = the vehicle ID 

 CCCCCCCCCCCC = the IP Address of the truck (excludes periods) 

 

 

My File 

Plow Sweeper 

PLCirus192168001200 PLCirus192168001201 SWCirus192168002155 

PL 
192168001201 
100220.LOG 

PL 
192168001201 
100221.LOG 

PL 
192168001201 
100222.LOG 
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Log Files – these are the files that contain the data extracted from the vehicle using the naming convention  

 

WWXXXXXXXXXXXXYYMMDD.LOG where: 

WW = first two characters of the truck type 

XXXXXXXXXXXX = the IP Address of the truck (excludes periods) 

YY = 2 digit year 

MM = 2 digit month 

DD = 2 digit day 

Updating Log files From DBD 2.2 to DBD 3 

This function allows data stored using the DBD 2 program to be updated to the new DBD 3 format so the data can be 

viewed using the Data Analysis Tool.   

Caution: The converter erases the DBD 2.2 files as they are transferred into the DBD3 format.  If you wish to keep 

a copy of the files in the DBD2.2 format, make a backup copy of the folder they are stored in.   

 

Step 1. 

For versions of DBD 3.6 or lower click: 

File->Update DBD 2.2 Log Files to DBD 3.   

 

For versions of DBD 3.7 or higher click: 

File->DBD2 Functions->Update DBD 2.2 Log Files to DBD3 

 

Step 2. 

 
 

A warning will appear which is a reminder to make each truck inactive.  The purpose of making the trucks inactive is to 

ensure that no trucks will download data while the conversion takes place.  If it is certain that no truck will be 

downloading while the conversion takes place this step can be ignored.  

 

Step 3. 

 
 

Select the folder that contains the DBD 2.2 files that you want converted.   
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Step 4. 

 
 

A dialog box will show up which lists all of the truck names from DBD2 and all of the trucks available in DBD3. 

 

Step 5. 

 
 

Select the truck from DBD2 which needs to be converted. 
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Step 6. 

 
 

Select the truck in DBD3 which the files will be converted into and click „OK‟. 

 

Step 7. 

 
 

The status bar will show the progress of the download. 

 

Repeat steps 1-7 for each truck that needs to be converted.  

 

All of the data is converted when step 1 is repeated and a popup box containing the text „Folder Does Not 

Contain the Necessary Files.(CFG)‟ appears. 
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Quick troubleshooting instructions for DBD 3 network connection (for technician with network experience): 

 

Make sure that all the IP addresses of the network components (PC, Access Point, Bridge, and SpreadSmart) are in the 

same subnet, but none of the IP addresses are identical.  Common setup mistakes include setting the spreader systems‟ IP 

address to the address listed on the sticker on the bridge or setting the trucks‟ IP address to the same as address as another 

truck in the fleet. 

 

From a command prompt on the PC, ping each component in the system from the PC to the SpreadSmart.  Start with the 

access point, then the bridge, then the SpreadSmart, to identify which link (if any) is having problems.  Failure to ping the 

access point indicates a network problem between the PC and access point.  Failure to ping the bridge indicates a wireless 

link problem, and failure to ping the SpreadSmart indicates a cabling problem between the bridge and the SpreadSmart. 

 

Check to make sure that the IP setting in the system setup of the SpreadSmart is NOT the default of 192.168.1.254, but 

that the last two decimal digits have been set to some other value. 

 

Check to make sure that the IP setting in the SpreadSmart system matches that in the Full Vehicle List of DBD 3. 
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TROUBLESHOOTING GUIDE 
 

Symptoms  Possible Causes Remedy 

Software will not 

install 

.NET 3.5 framework is 

not installed 

Go to Microsoft updates (windowsupdate.microsoft.com) 

and get the latest updates. 

Software will not 

install 

Incorrect operating 

system 

Drive By Download will only work with Windows XP and 

Windows 7 

DBD 3 cannot 

connect to 

SpreadSmart  

a) Incorrect IP address  

 

b) IP configuration 

incorrect 

 

a) SpreadSmart IP should not be still set at default 

192.168.1.254 

 

b) All component IP addresses must be unique in the same 

subnet 

Truck is always 

out of range.  

a) Truck not close enough 

 

 

 

 

 

b) Cable connection error 

 

 

 

 

c) IP addresses don‟t 

match 

 

 

 

d) Base station PC IP 

address error 

 

 

e) Ping truck to verify 

connection 

a) Confirm the truck is within the range of the access point 

by checking the WLAN LED on the bridge.   A blinking 

light indicates the bridge is in range.  A solid light or no light 

means unit is not within range. Cycle the power on the 

Spreadsmart/Datashark for 10 seconds. 

 

b) Check the WLAN light on the bridge.  It is the right most 

light, and should be blinking occasionally.  If not lit, check 

the data cable connection between the bridge and the Drive 

By Data port on the SpreadSmart
TM

  system. 

 

c) Verify the IP address in the System Setup of the 

SpreadSmart
TM

 and the IP address in the vehicle list in 

Drive By.exe both are the same & that no two trucks are 

those numbers. 

 

d) Verify that the network configuration settings on the host 

PC are correct, by opening a command window and typing 

IPCONFIG.  The IP settings should show an address in the 

192.168.96.x range. 

 

e) Verify a good connection to the truck using PING.  On the 

computer select Run and type command, type PING 

192.168.x.x where x is the IP address of the SpreadSmart
TM

 

unit.  If the command times out, reboot the computer and 

SpreadSmart
TM

 system (on the keypad) and try again. 

 

“error – no data 

card” 

a) Digital storage card 

missing from CPU 

 

b) Data card present, loss 

of connection 

a) Replace SD card in controller. 

 

 

 

b) Reset SpreadSmart (Keypad Switch) to “re-acquire” the 

connection to the data card. 

 “card  erase fail” MMC card did not 

properly erase during data 

transfer due to transient 

power 

Reset power on the SpreadSmart, wait 10 seconds and then 

attempt to download data again. 
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Symptoms  Possible Causes Remedy 

Windows Cannot 

Access 

„foldername’ 

DBD 3 cannot find the 

location to write log files 

to 

Check that the DBD 3 Log File Location exists and that the 

computer has access to that folder.  

Truck will not 

download even 

though it says 

„Truck In Range‟ 

The truck is set to be 

inactive 

Click on the truck in the Full Vehicle List, change the state 

of the truck in Vehicle Settings to Active. 

A connection 

attempt failed 

because the 

connected party 

did not properly 

respond after a 

period of time, or 

established 

connection failed 

because connected 

host has failed to 

respond 

192.168.1.xxx:23 

a)The IP Address entered 

for the device is the IP 

Address for a device that 

is not a Cirus controller 

 

b) happens when you turn 

the controller off during 

download before the 

Sockets have a chance to 

make a connection. 

 

a)Device exists and is able to ping, but it is not a Cirus 

Controls Device.  Could be anything a printer, phone, 

another computer. 

 

 

 

 

b) The Device lost power while a download was in process.  

Try using the 'Download' button to download again. 

An existing 

connection was 

forcibly closed by 

the remote host 

The computer with DBD 

3 on it started a 

download, then the 

computer lost the 

connection to the 

network. 

Make sure the computer is connected to the network and try 

to download again. 

No connection 

could be made 

because the target 

machine actively 

refused it 

The server is not running. Make sure the computer is connected to the network. 

Timed Out Truck was in range,then 

left range 

Retry download with manual “Download Vehicle Data” 

button. 

 

 

SUPPORT 

If you have any questions about your Drive by Download 
TM

 system or it‟s operation call the Cirus Controls Technical 

Support line at: (763) 493-9380. 

 

Technical Support is available Monday thru Friday from 7am to 5:00pm central time. You may also e-mail customer 

support with your questions at info@ciruscontrols.com. 
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GLOSSARY 
 

 
Configuration File – The configuration file allows all of the DBD 3 settings to be set up at the factory which allows for 

easy installation.  The file is namged DriveByDownloadConfigurationFile.cfg. 

 

DBD 3 – The 2010 version of Drive By Download. 

 

DBD 3 2.2 – The previous version of Drive By Download. 

 

Fleet – Refers to all of the trucks in the DBD 3 system. 

 

IP Address – A number assigned to each truck which it uses to communicate over the computer network.  Each truck in 

the fleet must have a unique IP Address. 

 

Log File – a file that contains the data collected from a cirus controls spreader. 

 

Log File Location – The folder where all of the downloaded Log Files are kept.  The location of the Log Files can be 

changed by selecting File->DBD 3 Log File Location. 

 

Subnet – A subnet mask is used to identify the network within the large network. 

 

Vehicle ID – 5 character ID given to a truck.  Each truck must have a unique vehicle ID unless it is given the generic label 

„Cirus‟. 

 

Vehicle Type – Trucks are given a type (i.e. Plow, Sweeper) that is used to help sort log files. 

 

Vehicle State – Classifies a truck as ACTIVE or INACTIVE.  Used to distinguish trucks in the fleet that are actively 

downloading, and those that are not actively downloading.  A truck might be made inactive if it is being repaired. 

 

 


